... Dashboard clock not working ...


This ad disappears when logged in

Rollo

Finally riding a big boys bike
Dec 29, 2016
368
1,220
61
Lincoln Park, United States
#1
... My recently acquired Goodyear bike is equipped with the repro speedo clock dashboard ... Speedo works great ... the clock not so much ... It's made in Germany so I'm assuming it's a decent time piece ...
I wound it slightly to see if it would tick and nothing ... Anyone know what might be my problem? ... I pushed and pulled on the winding stem thinking that might be it ... but nothing doing ... The only other visible thing on the back is the + - lever for what I assume is for clock speed ... Any thoughts appreciated ...

Bicycle-Speedometer-Stewart-Warner-clock-SCHWINN.jpg
 

bikecrazy

I live for the CABE
Dec 8, 2011
1,023
288
Mentor, United States
#3
As a last ditch effort, I would try to introduce some WD40 into the inner workings without getting any on the face.
 
Likes: Rollo

Rollo

Finally riding a big boys bike
Dec 29, 2016
368
1,220
61
Lincoln Park, United States
#4
As a last ditch effort, I would try to introduce some WD40 into the inner workings without getting any on the face.
... I'll give this a try first ... or maybe electrical contact cleaner ...Thanks ...
 

This ad disappears when logged in
Most Recent BUY IT NOW Items Listed on eBay
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture
eBay Auction Picture